PREREQUISITES FOR .NET 2.0  
Author Message
Quintino





PostPosted: Visual Studio Setup and Installation, PREREQUISITES FOR .NET 2.0 Top

i downloaded .net framework 2.0 .. but when i went install appear the message :"prerequisites not installed", why i want to know where i can take these prerequisites ... somebody help me please tanks


Visual Studio31  
 
 
QuanT





PostPosted: Visual Studio Setup and Installation, PREREQUISITES FOR .NET 2.0 Top

The Framework requires The windows installer 3.0 and IE 5.01.

You will also need MDAC 2.8 SP1 if you have data access scenarios but that's optional.


 
 
RajatTandon





PostPosted: Visual Studio Setup and Installation, PREREQUISITES FOR .NET 2.0 Top

I am using .NET 2.0 on windows 2000 professional. When I executed the "UsingSockets" sample given in 101 C# code samples, It gave me exception saying that "Feature requires Windows xp or later".  Exception line was socket.Disconnect(true) in the following method...

private static void SocketSendReceive(string server)

I don't understand why it cann't run on windows 2000. The target computers for our software will be windows 2000 machines with framework 2.0 installed. In the MSDN documentation, it's mentioned that windows 2000 sp4 qualifies the prerequisite of .NET 2.0 ...

http://msdn2.microsoft.com/en-us/library/system.platformnotsupportedexception.aspx

Please somebody tell me about such points. Since we cannot control the target computer's OS so should we revert back to visual studio 2003 in order to deploy the working software on our target machines or is there any patch which we need to install to avoid these issues