TFS Installation: Error 28905  
Author Message
Mike Thurber





PostPosted: Team Foundation Server - Setup, TFS Installation: Error 28905 Top

Hello,

I'm trying to install evaluation version of Team Foundation Server. I got the latest version, and the current installation instructions, from microsoft.com on July 19. Went throught the prerequisite sections of the Single Server instructions - patched, updated, and/or installed Windows Server 2003, .NET Framework, SQL Server 2005, IIS, Share Point. During installation of TFS itself, got "Error message 28905 WiDBLoc could not list of fields to localize from the database." Installation stopped at that point.

Does anybody know what could cause this, and what I can do to get past it

Any assistance greatly appreciated.

Mike Thurber



Visual Studio Team System44  
 
 
Matthew Mitrik MSFT





PostPosted: Team Foundation Server - Setup, TFS Installation: Error 28905 Top

Hi Mike,

Have you been able to get past this setup issue If not, please let me know and I will find someone to provide help.

Thanks,
-Matt



 
 
Jason Barile MSFT





PostPosted: Team Foundation Server - Setup, TFS Installation: Error 28905 Top

You might find this blog post helpful: http://geekswithblogs.net/pjhacker/archive/2005/11/02/58977.aspx

To quickly summarize - make sure you have TCP/IP enabled for your SQL database. If you've just enabled it, be sure to restart the SQL service to make sure the change takes effect.


 
 
Mike Thurber





PostPosted: Team Foundation Server - Setup, TFS Installation: Error 28905 Top

Thanks Jason - spot on! It was not intuitively obvious to me that SQL Server had to be restarted, but it did work.

Mike Thurber


 
 
Jason Barile MSFT





PostPosted: Team Foundation Server - Setup, TFS Installation: Error 28905 Top

I agree - I think we can make it more obvious in the installation guide, and I'll submit that suggestion. Glad to know you're up and running!
 
 
MikeSwe





PostPosted: Team Foundation Server - Setup, TFS Installation: Error 28905 Top

Hi Jason,

I just performed the same installation (180 day trial) and used the TFS Installation Guide (Last updated: April 13, 2007).

I hit the same error and it was solved in the same manner. However i double checked that i did not miss this in the manual (How to: Install Microsoft SQL Server 2005 for Team Foundation Server (Single-Server Deployment)) and there was nothing on enabling TCP/IP and that you need to restart SQL Service!

I'm sure future users would appreciate if the MS TFS team could add this little detail to the guide! Otherwise the installation was very smooth!

Cheers!

Mikael