strange behavior in IDE for foxpro...  
Author Message
Prima123





PostPosted: Mon Dec 29 09:32:31 CST 2003 Top

Exchange Servers >> strange behavior in IDE for foxpro...

Does anyone know what might be causeing this?

Every time I go into a project and try to use the builder it says it cant be
found... so i have to go reset the path to the builder each time the project
loads... but it's not just the builder it doesn't remember the path to...
there are a few others that get lost also... but when i make a brand new
project, it knows where the builder is! only older projects from foxpro 6
are doing this.. (this is foxpro 7 right now)

also, every time i run a form to test it, the controls toolbar (which i
docked onto the toolbar spot on the top) gets undocked and moved back to a
certin location (same place every time)... and the form window gets resized
to smaller then maximized like i had it (the form designer window) it's
getting kind of annoying and set as default in properties isn't helping much
either... it just forgets the settings every time...

any idea how to fix this? thanks

--
================================
Brian Henry
The Reschini Group
http://www.hide-link.com/

Exchange Server15  
 
 
Leemi





PostPosted: Mon Dec 29 09:32:31 CST 2003 Top

Exchange Servers >> strange behavior in IDE for foxpro... Hi Brian:

The first thing I would do is determine if VFP is using a Config.fpw file
that contains settings that overwrite the default values found in the
Tools> Options> File Locations dialog. Use the SYS(2019) function from the
Command window (?sys(2019) to see if VFP is finding a Config.fpw file
somewhere on your system.

Regarding the problem with the toolbar and windows being resized, I would
use the SYS(2005) function to determine if VFP is using a Foxuser file.
This resource file stores window sizes and positions, as well as toolbar
characteristics. If it is using a Foxuser file, you can either prevent it
from using a resource file (resource=off command in the Config.fpw file) or
point to another resource file (resource=<path>\foxuser.dbf in the
Config.fpw file).

I hope this helps.

This posting is provided "AS IS" with no warranties, and confers no rights.

Sincerely,
Microsoft FoxPro Technical Support
Lee Mitchell

*-- VFP8 HAS ARRIVED!! --*
Read about all the new features of VFP8 here:
http://www.universalthread.com/VisualFoxPro/News/VFP8Release.asp
Purchase VFP8 here:
http://shop.microsoft.com/Referral/Productinfo.asp?siteID=11518

Keep an eye on the product lifecycle for Visual FoxPro here:
http://support.microsoft.com/default.aspx?id=fh;[ln];lifeprodv
- VFP5 Mainstream Support retired June 30th, 2003
- VFP6 Mainstream Support retires Sept. 30th, 2003


>Does anyone know what might be causeing this?

>Every time I go into a project and try to use the builder it says it cant
be
>found... so i have to go reset the path to the builder each time the
project
>loads... but it's not just the builder it doesn't remember the path to...
>there are a few others that get lost also... but when i make a brand new
>project, it knows where the builder is! only older projects from foxpro 6
>are doing this.. (this is foxpro 7 right now)

>also, every time i run a form to test it, the controls toolbar (which i
>docked onto the toolbar spot on the top) gets undocked and moved back to a
>certin location (same place every time)... and the form window gets resized
>to smaller then maximized like i had it (the form designer window) it's
>getting kind of annoying and set as default in properties isn't helping
much
>either... it just forgets the settings every time...

>any idea how to fix this? thanks

>--
>================================
>Brian Henry
>The Reschini Group
>HTTP://www.reschini.com

 
 
Brian





PostPosted: Mon Dec 29 09:51:52 CST 2003 Top

Exchange Servers >> strange behavior in IDE for foxpro... thanks figured out the app path's errors.. the config file was blanking them
out with null strings...

--
================================
Brian Henry
The Reschini Group
HTTP://www.reschini.com


> Hi Brian:
>
> The first thing I would do is determine if VFP is using a Config.fpw file
> that contains settings that overwrite the default values found in the
> Tools> Options> File Locations dialog. Use the SYS(2019) function from the
> Command window (?sys(2019) to see if VFP is finding a Config.fpw file
> somewhere on your system.
>
> Regarding the problem with the toolbar and windows being resized, I would
> use the SYS(2005) function to determine if VFP is using a Foxuser file.
> This resource file stores window sizes and positions, as well as toolbar
> characteristics. If it is using a Foxuser file, you can either prevent it
> from using a resource file (resource=off command in the Config.fpw file)
or
> point to another resource file (resource=<path>\foxuser.dbf in the
> Config.fpw file).
>
> I hope this helps.
>
> This posting is provided "AS IS" with no warranties, and confers no
rights.
>
> Sincerely,
> Microsoft FoxPro Technical Support
> Lee Mitchell
>
> *-- VFP8 HAS ARRIVED!! --*
> Read about all the new features of VFP8 here:
> http://www.universalthread.com/VisualFoxPro/News/VFP8Release.asp
> Purchase VFP8 here:
> http://shop.microsoft.com/Referral/Productinfo.asp?siteID=11518
>
> Keep an eye on the product lifecycle for Visual FoxPro here:
> http://support.microsoft.com/default.aspx?id=fh;[ln];lifeprodv
> - VFP5 Mainstream Support retired June 30th, 2003
> - VFP6 Mainstream Support retires Sept. 30th, 2003
>
>
> >Does anyone know what might be causeing this?
>
> >Every time I go into a project and try to use the builder it says it cant
> be
> >found... so i have to go reset the path to the builder each time the
> project
> >loads... but it's not just the builder it doesn't remember the path to...
> >there are a few others that get lost also... but when i make a brand new
> >project, it knows where the builder is! only older projects from foxpro 6
> >are doing this.. (this is foxpro 7 right now)
>
> >also, every time i run a form to test it, the controls toolbar (which i
> >docked onto the toolbar spot on the top) gets undocked and moved back to
a
> >certin location (same place every time)... and the form window gets
resized
> >to smaller then maximized like i had it (the form designer window) it's
> >getting kind of annoying and set as default in properties isn't helping
> much
> >either... it just forgets the settings every time...
>
> >any idea how to fix this? thanks
>
> >--
> >================================
> >Brian Henry
> >The Reschini Group
> >HTTP://www.reschini.com
>