Exchange and Active Sync - Certificate Problems  
Author Message
RobertBollinger





PostPosted: Wed Nov 15 18:50:49 CST 2006 Top

Exchange Servers Setup >> Exchange and Active Sync - Certificate Problems

Hi,

I have a small problem.

I have a mail server which has an MX Record of mail.mydomain.com. We
are a small organization and have only a single SBS 2003 server. The
server's real name is servername.mydomain.com.

The issue is that when I publish a self signed certificate by my server
for mail.mydomain.com, OWA and ActiveSync through our Treos works
GREAT. But public folders give a certificate error because the
certificate for exchange is mail.mydomain.com, not
servername.mydomain.com.

So I switch it. Now public folders work GREAT but ActiveSync is
complaining because it is trying to access mail.mydomain.com and the
certificate says servername.mydomain.com. (error 0x80072F17)

Any suggestions on how to get BOTH working would be very much
appreciated.

Thanks.

Exchange Server3  
 
 
John





PostPosted: Wed Nov 15 18:50:49 CST 2006 Top

Exchange Servers Setup >> Exchange and Active Sync - Certificate Problems Did you install the new Cert on the Treo? Check the Cert store on the phone
to insure its installed.

--
John Oliver, Jr
MCSE, MCT, CCNA
Exchange MVP 2007
Microsoft Certified Partner



> Hi,
>
> I have a small problem.
>
> I have a mail server which has an MX Record of mail.mydomain.com. We
> are a small organization and have only a single SBS 2003 server. The
> server's real name is servername.mydomain.com.
>
> The issue is that when I publish a self signed certificate by my server
> for mail.mydomain.com, OWA and ActiveSync through our Treos works
> GREAT. But public folders give a certificate error because the
> certificate for exchange is mail.mydomain.com, not
> servername.mydomain.com.
>
> So I switch it. Now public folders work GREAT but ActiveSync is
> complaining because it is trying to access mail.mydomain.com and the
> certificate says servername.mydomain.com. (error 0x80072F17)
>
> Any suggestions on how to get BOTH working would be very much
> appreciated.
>
> Thanks.
>


 
 
K





PostPosted: Thu Nov 16 07:58:03 CST 2006 Top

Exchange Servers Setup >> Exchange and Active Sync - Certificate Problems Yes the cert was installed. THe error given by the phone was that the
certificate did not match the website (cert - servername.mydomain.com,
site-mail.mydomain.com).


> Did you install the new Cert on the Treo? Check the Cert store on the phone
> to insure its installed.
>
> --
> John Oliver, Jr
> MCSE, MCT, CCNA
> Exchange MVP 2007
> Microsoft Certified Partner
>


> > Hi,
> >
> > I have a small problem.
> >
> > I have a mail server which has an MX Record of mail.mydomain.com. We
> > are a small organization and have only a single SBS 2003 server. The
> > server's real name is servername.mydomain.com.
> >
> > The issue is that when I publish a self signed certificate by my server
> > for mail.mydomain.com, OWA and ActiveSync through our Treos works
> > GREAT. But public folders give a certificate error because the
> > certificate for exchange is mail.mydomain.com, not
> > servername.mydomain.com.
> >
> > So I switch it. Now public folders work GREAT but ActiveSync is
> > complaining because it is trying to access mail.mydomain.com and the
> > certificate says servername.mydomain.com. (error 0x80072F17)
> >
> > Any suggestions on how to get BOTH working would be very much
> > appreciated.
> >
> > Thanks.
> >

 
 
K





PostPosted: Thu Nov 16 08:57:56 CST 2006 Top

Exchange Servers Setup >> Exchange and Active Sync - Certificate Problems The only thing I can think of to do is to add an A record for
myserver.mydomain.com as well as the A record for mail.mydomain.com.

I think this would do the trick as it would resolve to the same IP as
mail.mydomain.com but the certificate on the phone would reflect the
same servername as the A record it was trying to contact.

Does that make sense?

Thanks.


> Yes the cert was installed. THe error given by the phone was that the
> certificate did not match the website (cert - servername.mydomain.com,
> site-mail.mydomain.com).
>

> > Did you install the new Cert on the Treo? Check the Cert store on the phone
> > to insure its installed.
> >
> > --
> > John Oliver, Jr
> > MCSE, MCT, CCNA
> > Exchange MVP 2007
> > Microsoft Certified Partner
> >


> > > Hi,
> > >
> > > I have a small problem.
> > >
> > > I have a mail server which has an MX Record of mail.mydomain.com. We
> > > are a small organization and have only a single SBS 2003 server. The
> > > server's real name is servername.mydomain.com.
> > >
> > > The issue is that when I publish a self signed certificate by my server
> > > for mail.mydomain.com, OWA and ActiveSync through our Treos works
> > > GREAT. But public folders give a certificate error because the
> > > certificate for exchange is mail.mydomain.com, not
> > > servername.mydomain.com.
> > >
> > > So I switch it. Now public folders work GREAT but ActiveSync is
> > > complaining because it is trying to access mail.mydomain.com and the
> > > certificate says servername.mydomain.com. (error 0x80072F17)
> > >
> > > Any suggestions on how to get BOTH working would be very much
> > > appreciated.
> > >
> > > Thanks.
> > >