DELETECOMMAND error in xsd  
Author Message
johnvarney





PostPosted: .NET Framework Data Access and Storage, DELETECOMMAND error in xsd Top

Trying to use Dataset designer in VS2005.

When I try to add a query to the TableAdapter, a SELECT query works but any DELETE, INSERT or UPDATE query causes MSDatasetGenerator to fail with an 'Object reference not set to an instance of an object' error.

A simple autogenerated query causes the problem:

<DbSource ConnectionRef="ProfilesConnectionString (Settings)" DbObjectName="" DbObjectType="Unknown" GenerateShortCommands="True" GeneratorSourceName="DeleteQuery" Modifier="Public" QueryType="NoData" ScalarCallRetval="System.Object, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" UseOptimisticConcurrency="True" UserGetMethodName="GetDataBy" UserSourceName="DeleteQuery">

<DeleteCommand>

<DbCommand CommandType="Text" ModifiedByUser="True">

<CommandText>DELETE FROM MemberData</CommandText>

<Parameters>

</Parameters>

</DbCommand>

</DeleteCommand>

</DbSource>

I have tried altering all the values but still get the problem. The only change I see is if the <DeleteCommand> is changed to a <SelectCommand>

Has anyone any idea what is going on This is making the whole Dataset Designer functionality unuseable.

Thanks

John



.NET Development27