I can't see any purpose of using this keyword with Function names and it also looks odd because they can be just called using FunctionFoo(); without any problem. There is not a problem which is available for variables and class field. Using this,better be limited to fileds only because there me be a scenerio where passed parameters to function and class's fields have the same name. e.g
private void SomeFunction(Employee employee)
this.employee = employee;
There is not any scenerio where this is really needed for function, because functions can be called in folowing ways:
Non static functions from other class:
Function from the same class:
So....... I think we should not use this atleast with functions.....