Unrecognized configuration section 'connectionStrings' on a Website  
Author Message
Malik01





PostPosted: Visual C# General, Unrecognized configuration section 'connectionStrings' on a Website Top

Hello,

First I developed my project in Visual Studio 2003 and it is running on a website quite well but now I want to add a sub project in it I developed this in Visual Studio 2005 but it is not working at all, It is giving error "Unrecognized configuration section 'connectionStrings'" PLease guide me ASAP how can I fix that problem

Remember I AM USING THIS ON INTERNET not on local machine or local IIS.

Regards,

Abubakar Malik

Netherlands

0031 64 2354713



Visual C#6  
 
 
timvw





PostPosted: Visual C# General, Unrecognized configuration section 'connectionStrings' on a Website Top

I presume that your webapplication is using the 1.x engine... And you need to configure your subapplication to use the 2.x engine instead...

 
 
Malik01





PostPosted: Visual C# General, Unrecognized configuration section 'connectionStrings' on a Website Top

Ya, you are right, same application is running fine on my local machine with Visual Studio 2005 but when I upload it on the internet it shows error you can check yourself while clicking here.

http://www.kerozen.eu/myBroadway/Default.aspx

Regards,

Abubakar Malik


 
 
timvw





PostPosted: Visual C# General, Unrecognized configuration section 'connectionStrings' on a Website Top

You mean you want information like http://quickstarts.asp.net/QuickStartv20/aspnet/doc/management/tools.aspx

(I don't have much experience with IIS configuration but i would presume that it's easiest to add a virtual directory to your existing 1.X application.. And then configurre that virtual directory to use asp.net 2.x...)


 
 
Malik01





PostPosted: Visual C# General, Unrecognized configuration section 'connectionStrings' on a Website Top

Hello,

As I told you earlier problem is not on my local computer. It runs fine when I run on my local computer I also checked its version, it is already 2.0 but when I upload same file on my website it shows error click here to see error. Please try to fix it as soon as possible.Plz.

Regards,

Abubakar


 
 
OmegaMan





PostPosted: Visual C# General, Unrecognized configuration section 'connectionStrings' on a Website Top

There is one other error which you might run into is a what version of .Net that ASP.Net is set to use. For example when one upgrades to .Net 2, asp.might still be set to use .Net 1x. To check/change it to use v2 do this:

aspnet_regiisCheck via aspnet_regiis in the Framework version directory such as:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis -lv
1.1.4322.0 Valid C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_isapi.dll
2.0.50727.0 Valid (Root) C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll


If root is on 1.1..do the following if the web service code is =compiled under version 2, to change that version use the command as follows:

aspnet_regiis -i.



 
 
James Curran





PostPosted: Visual C# General, Unrecognized configuration section 'connectionStrings' on a Website Top

You need to tell the administrator of the website you are using (www.kerozen.eu) that your folder needs to be a seaparate applications, and registered as a .Net v2.0 website.

He is probably going to tell you that this is not possible, inwhich case your only recourse is to re-write the application remove anything that v2.0 specific. You should be able to use the information provided in this thread to revert your local system to v1.1 for your testing.