Security Trimming - missing configuration?  
Author Message
Jason Kossowan





PostPosted: SharePoint - Setup, Upgrade, Administration and Operation, Security Trimming - missing configuration? Top

I have a new out of the box install of MOSS07 up and used it to crawl some legacy SP 2003 sites with Enterprise Search. The problem we're having is security t**** doesn't seem to be kicking in on the results - users are able to get links in the results page to items they don't have security access to (SP still prompts for credentials when the link to that resource is clicked).

I have one domain security account as both application identity and primary crawl ID - this ID was given permission to the legacy SP content. The content is indexed but like I said everyone can see it regardless of rights to that resource.

I'm having trouble finding articles on troubleshooting/configuring security t**** for MOSS07 - apparently it should work automagically. Any help would be much appreciated.

Thanks.



SharePoint Products and Technologies1  
 
 
Stephen-SP911





PostPosted: SharePoint - Setup, Upgrade, Administration and Operation, Security Trimming - missing configuration? Top

Mr. Kossowan,

When you say you are using 2007 to crawl some legacy sites, do you site have the 2003 server running or have you just moved these sites to 2007



 
 
Jason Kossowan





PostPosted: SharePoint - Setup, Upgrade, Administration and Operation, Security Trimming - missing configuration? Top

They are being hosted on their own hardware and SharePoint Server 2003 - we're just crawling them over the network.
 
 
Stephen-SP911





PostPosted: SharePoint - Setup, Upgrade, Administration and Operation, Security Trimming - missing configuration? Top

So do the links lead to the 2003 server or to the 2007 server

 
 
Jason Kossowan





PostPosted: SharePoint - Setup, Upgrade, Administration and Operation, Security Trimming - missing configuration? Top

The links are pointing at SharePoint 2003. These ACLs are being respected if I click the link. What is not being respected is the ACL permissions on the search results. With security t**** in SP2007 I'm not supposed to be seeing search results for items that I don't have access to (as long as the output cache is configured correctly). This is not happening so I'm wondering where I'm going wrong here.
 
 
Stephen-SP911





PostPosted: SharePoint - Setup, Upgrade, Administration and Operation, Security Trimming - missing configuration? Top

I think what is happening is that when you click the links the 2003 AC mechanism is what prompts you for a login just as it would if you found it directly on the 2003 server. Essentially I think 2007 is presenting the links as if they were outside content (on the internet for example) were its ACL has no meaning.

 
 
Jason Kossowan





PostPosted: SharePoint - Setup, Upgrade, Administration and Operation, Security Trimming - missing configuration? Top

The question is how do I get MOSS to respect the 2003 ACLs This is usually done via output cache configuration (I can have it use intranet output cache profile as opposed to internet) but I built this deployment as a fairly simple Search Center (no tabs) in the root of my web application and I don't have the option to configure output caching for this site collection. I thought maybe this was only available for a MOSS collection with publishing features enabled but turning them on did not give me the output cache options in the site collection administration. I'm at a loss why I don't have access to output cache configuration for my site.

Any pointers would help greatly. Thanks.